Donna sometimes not responding

Incident Report for Donna

Resolved

We've identified and resolved the issue. Donna is fully operational again.
Posted Feb 24, 2026 - 14:18 CET

Investigating

We're currently investigating an issue where Donna may not respond during some calls.

As a temporary workaround, please try calling again or use the chat instead.
Posted Feb 24, 2026 - 12:56 CET
This incident affected: Donna Voice Calling.